Apple’s new expensive line of Mac Pro computers seem to be causing a headache for a tiny fraction of the Mac userbase. According to several professional video editors who have contacted us or posted information to various online forums, the recent OS X 10.9.3 update is breaking compatibility between some Mac Pro graphics cards and video editing applications such as Adobe Premiere Pro and Blackmagic DaVinci Resolve…

Reported issues range from videos stalling during the export process, pink and green lines appearing in exported video, and overall application crashing and freezing. Obviously the presence of these bugs in large video production environments, especially on expensive machines running expensive software, is a real problem. Most users are reporting these issues on 2013 Mac Pros with the AMD D700 graphics engine, but some users are also reporting similar issues with D500 cards.

Screen Shot 2014-05-21 at 4.22.01 PM

It is unclear what exactly is causing the incompatibility problems (whether it be Apple’s hardware, 10.9.3, the applications, or the graphics cards), but one affected forum poster speculates that the issue revolves around the OpenGL and OpenCL drivers for the AMD chipsets. Other possibilities include that the incompatibly stems from Apple’s changes to how both Video RAM and external displays are handled.

Right now, there does not seem to be a perfect solution to this problem. One forum user says that using software-based rendering in Premiere Pro rather than GPU rendering is a fix, but this slows down export speed and makes having an expensive and powerful Mac Pro less useful. Another temporary solution is downgrading the system back to OS X 10.9.2, but some users may not have backups of their work, which would make downgrading a hassle.

The good news is that three of the four technology companies involved in this issue have made it clear that they are aware of the problem and are investigating it. One forum user says he spent an hour on the phone with Apple engineers looking into the problem:

Screen Shot 2014-05-21 at 4.13.46 PM

An Adobe Support Manager commented that he is investigating the issue:

Screen Shot 2014-05-21 at 4.14.06 PM

A representative from Blackmagic confirmed the issue and recommended that users turn back to OS X 10.9.2:

Screen Shot 2014-05-21 at 4.14.40 PM

It is unclear how this issue will eventually be resolved, but Apple is already testing OS X 10.9.4, so perhaps this future operating system update will include a remedy. We’ve reached out to Apple, Adobe, AMD, and Blackmagic for comment on this issue. Thanks, Joe Hoe for bringing this to our attention!