PSA: Update Chrome for Mac, as security flaw has been actively exploited

If you use Chrome for Mac, you’ll want to be sure it’s updated today: Google has just fixed a vulnerability that was being actively exploited by North Korean hackers … Google characterizes it as a high-risk flaw. This update includes 1 security fix. Please see the Chrome Security Page for more information. [$TBD][1170176] High CVE-2021-21148: … Continue reading PSA: Update Chrome for Mac, as security flaw has been actively exploited