As noted by MacRumors, Apple Final Cut Pro support documents strongly recommend updating to Mac OS 10.6.8

Updating to Mac OS X v10.6.8 or later is strongly recommended when using Final Cut Pro X, Motion 5, or Compressor 4.

Yeah, Apple.  Yeah.  (Readers are reporting no issues with 10.6.7 btw)

About the Author

Seth Weintraub's favorite gear