Ugh. It’s been happening since autocorrect on the iPhone. My name Isa, usually gets corrected to USA and my last name, Ranjha, to Roger. Of course I could hit that little bubble with my finger when the correction comes up, but I usually forget to. What about getting rid of autocorrect completely? Well that would work, yes, but sometimes it is really useful.

So what’s the solution to this, it’s actually incredibly simple. On your iPhone, navigate to the Settings.app, continue to General, then Keyboard, and scroll to the bottom. This is called keyboard shortcuts. If you haven’t touched this before, there should be a default entry for “On my way!” which will be suggested when you type ‘omw.’

What does this have to do with your name, and any other words autocorrect fails to understand? Tap on Add a new shortcut…, and in both boxes (phrase and shortcut) type in the correct spelling for the word and hit save. Now, the keyboard will never try to correct that word again!

You’re welcome. :)

About the Author