Sometimes users experience unusual bugs in Apple’s operating systems, and this is one of them. For some unknown reason, the iMessage link preview is now showing tweets with missing characters on iOS, macOS, and watchOS.

Every time you send a URL to another person or group in Apple’s Messages app, it generates a preview of that content. When the URL is from Twitter, iMessage has a specific template with a blue background to show the tweet without having to open it in the Twitter app.

Although the Twitter preview in iMessage is still working, it now hides the first and last character of a tweet. When exactly the bug started affecting users is unknown, but some of the 9to5Mac staff have been noticing it since Thursday.

The causes of the bug are also unclear, but we assume that it is related to a server-side issue – since these previews are generated online. In other words, there is probably something wrong with Twitter servers (or even iMessage’s) that has been resulting in broken previews.

Luckily, since this is probably a server-side bug, it should be fixed remotely in the next few hours (at least we hope so).

Were you affected by the bug? Let us know in the comments section below.

FTC: We use income earning auto affiliate links. More.


Check out 9to5Mac on YouTube for more Apple news:

You’re reading 9to5Mac — experts who break news about Apple and its surrounding ecosystem, day after day. Be sure to check out our homepage for all the latest news, and follow 9to5Mac on Twitter, Facebook, and LinkedIn to stay in the loop. Don’t know where to start? Check out our exclusive stories, reviews, how-tos, and subscribe to our YouTube channel

About the Author

Filipe Espósito

Filipe Espósito is a Brazilian tech Journalist who started covering Apple news on iHelp BR with some exclusive scoops — including the reveal of the new Apple Watch Series 5 models in titanium and ceramic. He joined 9to5Mac to share even more tech news around the world.